RSS

Cara Create Host Dota

26 Agu

Karena banyak pertanyaan seputar hal ini , meskipun sebenarnya informasi ini sudah ada di forum indogamers. Jadi untuk lebih mudah dan mudah2an bisa membantu. Tapi kalo masih gak bisa juga , saran gw baca lagi dan baca lagi… selebihnya gunakan forum. okeh. Buat Warnet2 / cybercafe yang blum bisa jadi host dota / create ( bahasa gaulnya katanya sih ), silahkan baca2 orat-oretan ini. Tutorial settingan untuk operating sistem Linux, Freebsd dan Mikrotik.
Bumbunya :

A Installation:
Go to this link and download these files, dont forget to read the readme.txt

http://www.indofiles.com/index.php?&direction=0&order=&directory=-GAMES%20INSTALLER-/DOTA%20INSTALLER

2. Bnetgatewayeditor.exe

Go to the dota folder that you’ve installed , find bnetgatewayeditor.exe , click it and go to the warcraft tab. Check if the gateway allready set :
Indogamers PRO ( 203.77.212.19 zone 7 )
Indogamers JUNIOR ( 203.77.212.20 zone 7 )

3. Ready to play.

Go to the desktop and find icon warcraft with name : indogamers. Chose the server ( PRO/JUNIOR ) that you wanna play, but you have to register your id first. Read the terms and aggrement if you wanna make PRO id. Go pm winnie or other admin in charge in Junior server.

B. How to create Rooms/Games ( host of the games ) :

These Router setting only for cybercafe staff/owner ( expert only )

Linux Router :

eth1 = local ethernet
eth0 = public ethernet

Step One

open /etc/rc.d/rc.local –> redhat, slackware,fedora , exect ubuntu using /etc/rc.local
type –> vi /etc/rc.d/rc.local

Step Two

Start editing , put these fit with your net configuration setting.
Forwarding public ip to lokal ip
[quote]

##First PC

/sbin/iptables -t nat -I PREROUTING -i eth1 -p tcp -d 202.159.53.20 –dport 6112 -j DNAT –to-destination 192.168.0.1:6112

/sbin/iptables -t nat -I PREROUTING -i eth1 -p udp -d 202.159.53.20 –dport 6112 -j DNAT –to-destination 192.168.0.1:6112

##Second Pc

/sbin/iptables -t nat -I PREROUTING -i eth1 -p tcp -d 202.159.53.20 –dport 6113 -j DNAT –to-destination 192.168.0.2:6113
/sbin/iptables -t nat -I PREROUTING -i eth1 -p udp -d 202.159.53.20–dport 6113 -j DNAT –to-destination 192.168.0.2:6113
[/quote]do the same with others pc, dont forget to fit the ip and port at the client pc and Games client port.

NEXT….

Step Three

[quote] /sbin/iptables -t nat -A POSTROUTING -o eth0 -s 192.168.0.0/24 -j SNAT –to-source 202.159.53.20

########## Create BY vampire_surfer , vampirezsr@gmail.com ################

[/quote]#Save/restore configuration
/sbin/iptables-save > /etc/sysconfig/iptables.rules
/sbin/iptables-restore < /etc/sysconfig/iptables.rules

From Step Two – Step Three put at the end of the /etc/rc.d/rc.local

After that .. press ESC , press :wq
esc+ : wq! –> saving /etc/rc.d/rc.local

Step Four ( Type in root terminal )
Quote:

/sbin/service iptables save
/sbin/iptables-save > iptables-rules
/sbin/iptables-restore < iptables-rules
/sbin/service iptables save
/sbin/service iptables restart

Set your games client port at Game play option port ( at the warcfart client ) fit with the rules that u put in your /etc/rc.d/rc.local

done.

Freebsd Router :
[b]BATTLE NET FREEBSD[/b]

Udah gw coba jalan bisa create jadi host , tapi satu network lom bisa join. klo mo test silahkan buat yang pake router pc freebsd.

rl0= ip external ( pub )
rl1=ip internal ( local )

[b]PERTAMA[/b]

Di [b]/etc/rc.conf [/b], harus ada ini ( kalo bisa dah recompiling kernel pada opsi [b]options IPFIREWALL and options IPDIVERT[/b] ) :
[quote]firewall_enable=”YES”
firewal_scripts=”/etc/fwrules”
natd_enable=”YES”
natd_interface=”rl0″
natd_flags=”-f /etc/natd.conf”[/quote]

[b]KEDUA[/b]

Buat file /etc/fwrules , isi dengan ini :
[quote]/sbin/ipfw -f flush
/sbin/ipfw add divert natd all from any to any via rl0
/sbin/ipfw add allow ip from any to any via rl0
/sbin/ipfw add allow ip from any to any via rl1[/quote]

[b]KETIGA[/b]

Buat file /etc/natd.conf , dan isi :

[QUOTE]

contain file /etc/natd.conf

###########################################

same_ports yes
dynamic yes

#kompi no 1

redirect_port tcp 192.168.0.1:6112 202.53.245.38:6112
redirect_port udp 192.168.0.1:6112 202.53.245.38:6112

#kompi no 6

redirect_port tcp 192.168.0.6:6117 202.53.245.38:6117
redirect_port udp 192.168.0.6:6117 202.53.245.38:6117

#kompi no 12

redirect_port tcp 192.168.0.12:6123 202.53.245.38:6123
redirect_port udp 192.168.0.12:6123 202.53.245.38:6123

#kompi no 18

redirect_port tcp 192.168.0.18:6129 202.53.245.38:6129
redirect_port udp 192.168.0.18:6129 202.53.245.38:6129

#kompi no 24

redirect_port tcp 192.168.0.24:6135 202.53.245.38:6135
redirect_port udp 192.168.0.24:6135 202.53.245.38:6135

#kompi no 30

redirect_port tcp 192.168.0.30:6142 202.53.245.38:6142
redirect_port udp 192.168.0.30:6142 202.53.245.38:6142

#masquerade ala vampire_surfer haha

redirect_port tcp 192.168.0.200:6112-6142 6112-6142
redirect_port udp 192.168.0.200:6112-6142 6112-6142

#written by vampire_surfer, greetz to [email=” indofreebsd@irc.dal.net”][color=#0000ff] indofreebsd@irc.dal.net[/color][/email]

#contact me [email=” vampire.surfer@gmail.com”][color=#0000ff] vampire.surfer@gmail.com[/color][/email]

[/QUOTE]

Lalu /sbin/reboot –> reboot pc router.
Damned di handbook gak ada hiks… capek dah ::swt:: untung berhasil…

Mikrotik router :

Contoh :

ip public lu : 202.123.3.2
ip local ( pc client ) : 192.168.0.101-sampe sebanyak2nya kompi lu dah.. zzz

- Buka Terminal di winbox , copy paste yang ada dibawah ini ( susun dulu yah biar rapih , sesuai dengan ip lu / settingan lu ).

/ip firewall nat

add chain=dstnat dst-address=(Masukin Ip pub /external, contoh 202.123.3.2 ) protocol=tcp src-port=6001 action=dst-nat to-addresses=192.168.0.101 to-ports=6001

add chain=dstnat dst-address=(Masukin Ip pub /external, contoh 202.123.3.2 ) protocol=tcp src-port=6002 action=dst-nat to-addresses=192.168.0.102 to-ports=6002

add chain=dstnat dst-address=(Masukin Ip pub /external, contoh 202.123.3.2 ) protocol=tcp src-port=6003 action=dst-nat to-addresses=192.168.0.103 to-ports=6003

add chain=dstnat dst-address=(Masukin Ip pub /external, contoh 202.123.3.2 ) protocol=tcp src-port=6004 action=dst-nat to-addresses=192.168.0.104 to-ports=6004

add chain=dstnat dst-address=(Masukin Ip pub /external, contoh 202.123.3.2 ) protocol=tcp src-port=6005 action=dst-nat to-addresses=192.168.0.105 to-ports=6005

add chain=dstnat dst-address=(Masukin Ip pub /external, contoh 202.123.3.2 ) protocol=tcp src-port=6006 action=dst-nat to-addresses=192.168.0.106 to-ports=6006

add chain=dstnat dst-address=(Masukin Ip pub /external, contoh 202.123.3.2 ) protocol=tcp src-port=6007 action=dst-nat to-addresses=192.168.0.107 to-ports=6007

add chain=dstnat dst-address=(Masukin Ip pub /external, contoh 202.123.3.2 ) protocol=tcp src-port=6008 action=dst-nat to-addresses=192.168.0.108 to-ports=608

add chain=dstnat dst-address=(Masukin Ip pub /external, contoh 202.123.3.2 ) protocol=tcp src-port=6009 action=dst-nat to-addresses=192.168.0.109 to-ports=609

add chain=dstnat dst-address=(Masukin Ip pub /external, contoh 202.123.3.2 ) protocol=tcp src-port=6010 action=dst-nat to-addresses=192.168.0.110 to-ports=6010

add chain=dstnat dst-address=(Masukin Ip pub /external, contoh 202.123.3.2 ) protocol=tcp src-port=6011 action=dst-nat to-addresses=192.168.0.111 to-ports=6011

add chain=dstnat dst-address=(Masukin Ip pub /external, contoh 202.123.3.2 ) protocol=tcp src-port=6012 action=dst-nat to-addresses=192.168.0.112 to-ports=6012

add chain=dstnat dst-address=(Masukin Ip pub /external, contoh 202.123.3.2 ) protocol=tcp src-port=6013 action=dst-nat to-addresses=192.168.0.113 to-ports=6013

add chain=dstnat dst-address=(Masukin Ip pub /external, contoh 202.123.3.2 ) protocol=tcp src-port=6014 action=dst-nat to-addresses=192.168.0.114 to-ports=6014

add chain=dstnat dst-address=(Masukin Ip pub /external, contoh 202.123.3.2 ) protocol=tcp src-port=6015 action=dst-nat to-addresses=192.168.0.115 to-ports=6015

add chain=dstnat dst-address=(Masukin Ip pub /external, contoh 202.123.3.2 ) protocol=tcp src-port=6016 action=dst-nat to-addresses=192.168.0.116 to-ports=6016

add chain=dstnat dst-address=(Masukin Ip pub /external, contoh 202.123.3.2 ) protocol=tcp src-port=6017 action=dst-nat to-addresses=192.168.0.117 to-ports=6017

add chain=dstnat dst-address=(Masukin Ip pub /external, contoh 202.123.3.2 ) protocol=tcp src-port=6018 action=dst-nat to-addresses=192.168.0.118 to-ports=6018

add chain=dstnat dst-address=(Masukin Ip pub /external, contoh 202.123.3.2 ) protocol=tcp src-port=6019 action=dst-nat to-addresses=192.168.0.119 to-ports=6019

add chain=dstnat dst-address=(Masukin Ip pub /external, contoh 202.123.3.2 ) protocol=tcp src-port=6020 action=dst-nat to-addresses=192.168.0.120 to-ports=6020

add chain=dstnat dst-address=(Masukin Ip pub /external, contoh 202.123.3.2 ) protocol=tcp src-port=6021 action=dst-nat to-addresses=192.168.0.121 to-ports=6021

add chain=dstnat dst-address=(Masukin Ip pub /external, contoh 202.123.3.2 ) protocol=tcp src-port=6022 action=dst-nat to-addresses=192.168.0.122 to-ports=6022

add chain=dstnat dst-address=(Masukin Ip pub /external, contoh 202.123.3.2 ) protocol=tcp src-port=6023 action=dst-nat to-addresses=192.168.0.123 to-ports=6023

add chain=dstnat dst-address=(Masukin Ip pub /external, contoh 202.123.3.2 ) protocol=tcp src-port=6024 action=dst-nat to-addresses=192.168.0.124 to-ports=6024

add chain=dstnat dst-address=(Masukin Ip pub /external, contoh 202.123.3.2 ) protocol=tcp src-port=6025 action=dst-nat to-addresses=192.168.0.125 to-ports=6025

add chain=dstnat dst-address=(Masukin Ip pub /external, contoh 202.123.3.2 ) protocol=tcp src-port=6026 action=dst-nat to-addresses=192.168.0.126 to-ports=6026

add chain=dstnat dst-address=(Masukin Ip pub /external, contoh 202.123.3.2 ) protocol=tcp src-port=6027 action=dst-nat to-addresses=192.168.0.127 to-ports=6027

add chain=dstnat dst-address=(Masukin Ip pub /external, contoh 202.123.3.2 ) protocol=tcp src-port=6028 action=dst-nat to-addresses=192.168.0.128 to-ports=6028

add chain=dstnat dst-address=(Masukin Ip pub /external, contoh 202.123.3.2 ) protocol=tcp src-port=6029 action=dst-nat to-addresses=192.168.0.129 to-ports=6029

add chain=dstnat dst-address=(Masukin Ip pub /external, contoh 202.123.3.2 ) protocol=tcp src-port=6030 action=dst-nat to-addresses=192.168.0.130 to-ports=6030

add chain=dstnat dst-address=(Masukin Ip pub /external, contoh 202.123.3.2 ) protocol=tcp src-port=6031 action=dst-nat to-addresses=192.168.0.131 to-ports=6031

add chain=dstnat dst-address=(Masukin Ip pub /external, contoh 202.123.3.2 ) protocol=tcp src-port=6032 action=dst-nat to-addresses=192.168.0.132 to-ports=6032

add chain=dstnat dst-address=(Masukin Ip pub /external, contoh 202.123.3.2 ) protocol=tcp src-port=6033action=dst-nat to-addresses=192.168.0.133 to-ports=6033

add chain=dstnat dst-address=(Masukin Ip pub /external, contoh 202.123.3.2 ) protocol=tcp src-port=6034 action=dst-nat to-addresses=192.168.0.134 to-ports=6034

add chain=dstnat dst-address=(Masukin Ip pub /external, contoh 202.123.3.2 ) protocol=tcp src-port=6035 action=dst-nat to-addresses=192.168.0.135 to-ports=6035

add chain=dstnat dst-address=(Masukin Ip pub /external, contoh 202.123.3.2 ) protocol=tcp src-port=6036 action=dst-nat to-addresses=192.168.0.136 to-ports=6036

add chain=dstnat dst-address=(Masukin Ip pub /external, contoh 202.123.3.2 ) protocol=tcp src-port=6037 action=dst-nat to-addresses=192.168.0.137 to-ports=6037

add chain=dstnat dst-address=(Masukin Ip pub /external, contoh 202.123.3.2 ) protocol=tcp src-port=6038 action=dst-nat to-addresses=192.168.0.138 to-ports=6038

add chain=dstnat dst-address=(Masukin Ip pub /external, contoh 202.123.3.2 ) protocol=tcp src-port=6039 action=dst-nat to-addresses=192.168.0.139 to-ports=6039

add chain=dstnat dst-address=(Masukin Ip pub /external, contoh 202.123.3.2 ) protocol=tcp src-port=6040 action=dst-nat to-addresses=192.168.0.140 to-ports=6040

add chain=dstnat dst-address=(Masukin Ip pub /external, contoh 202.123.3.2 ) protocol=tcp src-port=6041 action=dst-nat to-addresses=192.168.0.141 to-ports=6041

add chain=dstnat dst-address=(Masukin Ip pub /external, contoh 202.123.3.2 ) protocol=tcp src-port=6042 action=dst-nat to-addresses=192.168.0.142 to-ports=6042

aadd chain=dstnat dst-address=(Masukin Ip pub /external, contoh 202.123.3.2 ) protocol=tcp src-port=6043 action=dst-nat to-addresses=192.168.0.143 to-ports=6043

add chain=dstnat dst-address=(Masukin Ip pub /external, contoh 202.123.3.2 ) protocol=tcp src-port=6044 action=dst-nat to-addresses=192.168.0.144 to-ports=6044

add chain=dstnat dst-address=(Masukin Ip pub /external, contoh 202.123.3.2 ) protocol=tcp src-port=6045 action=dst-nat to-addresses=192.168.0.145 to-ports=6045

add chain=dstnat dst-address=(Masukin Ip pub /external, contoh 202.123.3.2 ) protocol=tcp src-port=6046 action=dst-nat to-addresses=192.168.0.146 to-ports=6046

add chain=dstnat dst-address=(Masukin Ip pub /external, contoh 202.123.3.2 ) protocol=tcp src-port=6047 action=dst-nat to-addresses=192.168.0.147 to-ports=6047

add chain=dstnat dst-address=(Masukin Ip pub /external, contoh 202.123.3.2 ) protocol=tcp src-port=6048 action=dst-nat to-addresses=192.168.0.148 to-ports=6048

add chain=dstnat dst-address=(Masukin Ip pub /external, contoh 202.123.3.2 ) protocol=tcp src-port=6049 action=dst-nat to-addresses=192.168.0.149 to-ports=6049

- Langkah terakhir , masquerade network 192.168.0.0/24

# /ip firewall nat add chain=srcnat src-address=192.168.0.0/24 action=masquerade

- Selesai, mudah kan.

About these ads
 
2 Komentar

Ditulis oleh pada 26 Agustus 2007 in Web

 

2 responses to “Cara Create Host Dota

  1. NoFee

    4 April 2010 at 3:53 AM

    Mantab banget artikelnya…
    terima kasih untuk infonya.

     
    • abunabiha

      22 Mei 2011 at 2:45 AM

      Semoga linknya bermanfaat ya pa nofee

       

Tinggalkan Balasan

Isikan data di bawah atau klik salah satu ikon untuk log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Logout / Ubah )

Twitter picture

You are commenting using your Twitter account. Logout / Ubah )

Facebook photo

You are commenting using your Facebook account. Logout / Ubah )

Google+ photo

You are commenting using your Google+ account. Logout / Ubah )

Connecting to %s

 
Ikuti

Get every new post delivered to your Inbox.

%d bloggers like this: